2022年2月16日 9時頃~17日12:30頃にかけて、「SATORI」から配信されるシステムメールが一部届かない事象が発生しておりました。現在は一次対応を行い、事象が解消されていることを確認しております。
ご迷惑をおかけしておりまして誠に申し訳ございません。
■事象
2022年2月16日 9時頃~17日12:30頃にかけて、「SATORI」から配信されるシステムメールが一部届かない事象が発生しておりました。
■発生期間
2022年2月16日 9時頃~17日12:30頃
■影響範囲
2022年2月16日 9時頃~11時頃に、「gmail.com」ドメインまたはGoogle Workspaceをご利用のドメインで、かつ、以下の「SATORI」からのシステムメール(※1)の送信先となったメールアドレス
※1:システムメールは送信元「noreply@system.satr.jp」から送信されます。
・サインアップ時の確認用メール
・ユーザー招待のお知らせメール
・セグメント一括登録 処理終了のお知らせメール
・カスタマ―一括登録 処理終了のお知らせメール
・カスタマ―一括削除 処理終了のお知らせメール
・ カスタマー情報CSV出力 処理終了のお知らせメール
・キャンペーンのレポートメール
・アカウントロックのお知らせメール
■原因
2022年2月16日 9時頃~11時頃に「Gmail」で障害が発生していたとみられており(※2)、本事象はこの障害の影響を受けて発生していた可能性が高いと判断しております。
具体的には、以下2つの原因が考えられます。
①2022年2月16日 9時頃~11時頃に発生したとみられている「Gmail」側の障害が原因で、「gmail.com」ドメインまたはGoogle Workspaceをご利用のドメインのメールアドレス宛にシステムメールが届いていなかった。
②2022年2月16日 9時頃~11時頃の「Gmail」側の障害発生期間に、「SATORI」上で複数回のジョブのリクエスト(完了時に上記システムメールが送られる処理)が行われ、メールの配信失敗が繰り返された。このことが原因で、対象のメールアドレスが、「SATORI」のシステムがメール送信の仕組みとして採用している外部サービス(以下、メール配信システム)によりエラーアドレスであると判定された。
※2:「Gmail」からの公式発表がありませんが、「SATORI」が利用しているメール配信システムにて確認された情報となります。
■対応経緯
2022年2月17日 12時30分頃、一次対応としてシステムメールのメール配信システムを切り替える作業を行い、事象が解消している事を確認しております。
・2022年2月16日 9時頃~11時頃にかけて
「Gmail」にて障害が発生(したとみられる)
・同日
お問い合わせをいただき調査開始
・2022年2月17日 12:30頃
一次対応としてシステムメールのメール配信システムを切り替える作業を実施
※一時的に切り替えているメール配信システムを戻す際には、追って本ページにてお知らせいたします
■関連情報
「Gmail」にて障害が発生していたとみられる2022年2月16日 9時頃~11時頃にかけて、「SATORI」から「gmail.com」ドメインまたはGoogle Workspaceをご利用のドメインのメールアドレス宛にカスタマーメールを送信していた場合、対象カスタマーにはメールが届いていなかった可能性があります。
これは、「SATORI」のシステムによる問題ではなく、「Gmail」の障害によるものであると考えられますが、その副次的な影響として「SATORI」のカスタマーリスト内の対象カスタマーの「配信ステータス」が「アドレス不正」(メール送信ができないステータス)になる事象が確認されております。
こちらについてなんらかの対応が可能かどうかについては、調査・検討中です。追って本ぺージにてお知らせいたします。
■2022年2月21日追記
Google Workspaceサポートへの確認の結果、2022年2月16日 8時頃~11時頃にかけて、「Gmail」にて”メッセージが拒否される”という障害が発生していたことが確認できました。
本お知らせページに記載の障害は「Gmail」の障害の影響を受けたものとなります。 なお、この影響により上記「関連情報」に記載した事象が発生しておりましたが、以下の対応を行う方針で準備を進めております。実施する日程が確定次第、追って本ページにてお知らせいたします。
<今後の対応(予定)>
「Gmail」の障害の影響により、「配信ステータス」が不適切に変更されたカスタマーに対して、「配信ステータス」のリカバリー対応を行います。 具体的には、カスタマーリスト内のカスタマーの「配信ステータス」が本障害により「アドレス不正」(メール送信ができないステータス)に変更されたカスタマーを特定し、「未確認」(メール送信ができるステータス)に変更する処理を行う予定です。
■2022年2月25日追記
「Gmail」の障害の影響により、「配信ステータス」が不適切に変更されたカスタマーに対して、「配信ステータス」のリカバリー対応を完了しました。
2022年2月25日 17:25以降は正しくメール送信されるようになっております。
※配信先のカスタマーの「配信ステータス」が「未確認」である場合、初回送信とみなされ、通常よりも低速配信をする仕様となっておりますが、配信ステータスが確認され次第配信スピードは回復いたしますのでご安心ください。
ご迷惑をおかけしておりまして誠に申し訳ございません。
ご不明点・ご懸念点がございましたら「SATORI」サポートセンター宛てにご連絡くださいませ。
※SATORIサポートセンターへのお問い合わせ方法はこちら