この度、アクセス企業機能について一部時間帯のアクセスが反映されない事象が発生しておりました。原因を特定し、対応を行いました。 発生期間中のデータの復旧対応については現在検討中です。決まり次第改めて本ページにてお知らせいたします。
- 2022年4月8日追記
2022年3月1日より過去6ヶ月分のデータの復旧を開始し、現在、対象期間の「アクセス企業詳細」に関連するデータのリカバリーが完了済みとなっております。「■発生期間」と「■対応経緯/解消見込み」を更新しておりますのでご確認ください。 - 2022年5月19日追記
2022年3月1日より過去6ヶ月分のデータの復旧を進めておりましたが、現在、対象期間のアクセス企業リスト画面のトータルスコア等の数値レポートについて、過去にさかのぼって2021年12月分までリカバリー完了しています。「■対応経緯/解消見込み」を更新しておりますのでご確認ください。 - 2022年5月26日追記
全てのデータ復旧が完了しました。「■対応経緯/解消見込み」「再発防止」を更新しておりますのでご確認ください。
データ復旧・解消までにお時間をいただき、また、本事象によりご迷惑をおかけしましたこと、申し訳ございませんでした。
■事象
アクセス企業機能について、一部時間帯のアクセスが反映されない事象が発生しておりました。
■発生期間
現在調査中となります。
※2022年2月14日 15:00以降のアクセスは正しく反映されております。
- 2022年4月8日追記
2021年9月1日までさかのぼって事象発生を確認いたしました。
(復旧対象を過去半年までさかのぼったの2021年9月1日以降のデータとし、それより前の期間の調査は打ち切らせていただきます。)
■影響範囲
「アクセス企業」機能において表示される「アクセス企業リスト」および「アクセス企業詳細」の一部
■原因
「アクセス企業」機能において表示される「アクセス企業リスト」および「アクセス企業詳細」は、システム内部のレポート処理として、定期的(1時間に一度)にバッチ処理を行って管理画面へ反映させております。
バッチ処理につきましては、想定されるデータ量に基づいて設計を行っておりましたが、この度、想定を超えるアクセスデータがあった場合に、スケジュールされていた次のバッチ処理がスキップされる、という事象が発生しておりました。
■対応経緯/解消見込み
・2022年1月24日
お問い合せをいただき調査開始
・2022年2月10日 21:30ころ
本事象が判明
・2022年2月14日 15:00ころ
本事象に対する対応(バッチサーバーの処理基盤の分散)を実施
・発生期間中に管理画面へ反映できなかったレポートについて 今後データの復旧を予定しております。 詳細は検討中のため、追って本ページにてお知らせいたします。
- 2022年4月8日追記
・2022年3月1日より
過去半年までさかのぼった2021年9月1日以降のデータの復旧を開始
・2022年4月4日
2021年9月分以降のアクセス企業詳細に関連するデータのリカバリーが完了済みであることを確認。
今後、アクセス企業リスト画面のトータルスコア等のリカバリーを進めていきます。
※復旧目途が分かり次第本ページを更新いたします。 - 2022年5月19日追記
アクセス企業リスト画面のトータルスコア等の数値レポートのリカバリーについて、過去にさかのぼって2021年12月分までリカバリーが完了済みであることを確認。
今後、残りの2021年9~11月分のリカバリーを進めていきます。 - 2022年5月26日追記
アクセス企業リスト画面のトータルスコア等の数値レポートのリカバリーについて、過去にさかのぼって2021年9月分までリカバリーが完了済みであることを確認。
■再発防止
検討中につき、確定次第追って本ページにてお知らせいたします。
- バッチ処理の分割対応により、時間帯の抜けが出ないようバッチ処理の構成を変更します。
- 監視設定の追加を行います。
バッチ処理が起動できなかった際に通知する設定を追加しました。
これにより、バッチ処理が起動できなかった際に検知し、対応できる体制を整えます。
ご迷惑をおかけしておりまして誠に申し訳ございません。
ご不明点・ご懸念点がございましたらSATORIサポートセンター宛てにご連絡くださいませ。
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